Author Topic: A Curiosity: USB errors at startup, plus a balky flash memory reader - SOLVED  (Read 48 times)

The Gorn

  • I absolutely DESPISE improvised sulfur-charcoal-salt peter cannons made out of hollow tree branches filled with diamonds as projectiles.
  • Trusted Member
  • Wise Sage
  • ******
  • Posts: 22412
  • Gorn Classic, user of Gornix
Since late May of this year, my Intel i7 desktop running Mint 18.3 has displayed the following messages (and messages similar to these) at every system power up.

I poked around in Linux forums for several hours and finally gave up. I assumed that there was something flaky about my USB interface(s) on the motherboard but everything else worked USB wise (including a printer/scanner, and downloading images from a camera USB port) so I didn't do anything about it and chalked it up to an old system.

So lately, as an unrelated thing I did:

I started to use a "GoPro" type action camera again when bike riding. I had a bunch of video clips on a micro SD card. So I needed to use the flash card reader.

I put the card in a SD card carrier and inserted it into the attached flash card reader. (Which internally is an "ATECH" brand chipset and which connects to a USB header pin array on the motherboard.)  The reader simply doesn't see the card. No flashing light on the reader.

In fact, I can't remember using the flash reader successfully since I went to Linux. So I started to track this issue down online. Most articles advised using the command "lsusb" to list all of the USB interfaces and devices. The only device showing was a mouse.

I then remembered - when this box ran Windows 7, I had intermittent unresolved problems with the same card reader there, too. Inserting a memory card did nothing. I would wind up opening the PC case up, and unplugging and re-plugging the card reader. This would "goose" the card reader and PC into operating and recognizing the card reader and also the inserted card.

So, realizing this recently, I opened the case and replugged the same card reader in the mobo. SOLVED. The card reader now shows up in a lsusb listing, and inserting a memory card causes it to be mounted in Linux automatically.

I also found something else, too.

Powering the box down after doing this, and then powering it back up...

The USB errors at startup completely disappeared.

My theory:

The power supply and motherboard always supply current to the USB ports (you can leave devices plugged into the PC to charge) even when the PC is "shut down", not running. There is always a red pilot light lit on the flash card reader even at power down.

My working theory now is that:

Somehow the flash card reader's USB interface enters a locked up or conflicted state.

The fact that power is always applied by the power supply means that the flash card reader never shuts down and therefore the locked-up non functional state remains the rule. The always on flash reader probably had been powered up for weeks or months, since the last time I opened up and worked on the system.

Unplugging/replugging the flash card USB header resets the flash card reader, removing power from the reader, so the error state resets. Good as "new".

Lastly, when the flash card reader was in this bad/invalid state, it interfered with the USB devices or bus at system startup, causing the Linux startup messages about USB problems. These errors (I looked them up) literally mean that the USB interface power is inadequate.

Possibly this contributed to excessively slow Windows boot load times as well when I ran Windows on this box.

MY FIX FOR THIS: (very simple)

The fix is to defeat the always-on USB power state of the computer.

I do so by turning off the toggle switch on the back of the power supply, on the back of the case - after I shut the OS down.

After a few seconds the flash card pilot light goes out.

This restores everything to an absolutely powered off state, so bad logic states, etc don't persist literally for weeks. 

This would have been a very good thing to do as a standard procedure, anyway. The USB doesn't need to stay semi powered up perpetually. I use transformers for my phones and gadgets.

Anyway, problem solved.
Gornix is protected by the GPL. *

* Gorn Public License. Duplication by inferior sentient species prohibited.